Results 1 to 4 of 4

Thread: Digital 6al on a 90 Celica

  1. #1
    Join Date
    Sep 2018
    Posts
    2

    Default Digital 6al on a 90 Celica

    As the title says I'm trying to install a digital 6al onto a 1990 Toyota Celica with a 2.2l engine (5sfe) I've got MSD wires and a Blaster 2 coil. I've installed the box as per the "general import" diagram. The box seems to work as the LED lights up and the rpm check works. What's happening is as soon as the car starts it dies again. It fires but then doesn't keep running. I've got the box disconnected for now till I can get some help.

  2. #2
    Join Date
    Jan 2018
    Posts
    57

    Default

    Where are the main power and ground going to? as well as the small red wire?
    shake-n-bake

  3. #3
    Join Date
    Sep 2018
    Posts
    2

    Default

    The battery has been relocated to the trunk so heavy red goes to a power distribution block from the battery. Heavy black goes directly to the chassis small red goes to my original coil positive wire white goes to the original coil negative. Orange goes to the blaster 2 positive and black to the blaster 2 negative.

  4. #4
    Join Date
    Jan 2018
    Posts
    57

    Default

    check on the small red wire to see how much voltage your getting while cranking. it needs to see more then 10 volts
    shake-n-bake

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •