Results 1 to 3 of 3

Thread: Ready to run dist after system short won't run over 2000 rpm

  1. #1
    Join Date
    Oct 2018
    Posts
    2

    Default Ready to run dist after system short won't run over 2000 rpm

    I have a ready to run distributor that was repaired by MSD early this year and has performed great! In a big block Chevy gasser. I was racing 2 weeks ago, launched hard as usual, and the entire electrical system went dead. Found the main power wire from starter/battery to rest of car had come loose and was smashed between the trans dipstick and the firewall, and had melted and welded itself to the dipstick tube shorting the entire system out. Repaired/replaced the wire and secured it. All worked well, but when I went to test drive the car, it won't run over 2k rpm - sputters, bangs, almost like it was on the rev limiter. Turned off the ignition and turned it back on to see if tach moved to 2000 like the rev limiter somehow got set, but the tach goes to 0. Could the short have fried the dist module or something? How would I test the module? Hoping you can help.

  2. #2
    Join Date
    Oct 2018
    Posts
    2

    Default

    Any help here as to how to test the module? Is the module bad from the power short?
    Camaroholic208

  3. #3
    Join Date
    Jan 2018
    Posts
    57

    Default

    yes it does sounds like there is some damaged caused to the module. send it in to us again so we can get the module replaced
    shake-n-bake

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •