Results 1 to 10 of 10

Thread: tach adaptor smoking

  1. #1
    Join Date
    Sep 2018
    Posts
    6

    Default tach adaptor smoking

    Hi i have installed MSD 6 al in car a few months back works fine big improvement.
    last week purchased 8920 tach adaptor to get the standard voltage triggered tach in the standard dash cluster to work.
    wired up as per install instructions.
    started car tach still not working car then stalled re fired engine started to smell tach adaptor and noticed it smoking.
    stopped car deleted the box re started car less tach adaptor.
    what has gone wrong?

  2. #2
    Join Date
    Jan 2018
    Posts
    57

    Default

    how do you have it wired in? where are the main power and ground going to?
    shake-n-bake

  3. #3
    Join Date
    Sep 2018
    Posts
    6

    Default

    msd 6al box wiring
    power lead and heavy red to starter motor as battery is in the boot
    black earth on body
    red ignition supply
    orange + coil
    black - coil
    white not used
    violet and green to distributor
    grey to tacho and shift light

    car has run fantastic like this msd 6al only

    tach adaptor wired in
    grey from 6al to white on adaptor
    black to earth
    violet to tacho and shift light
    red to ignition
    car started no tach working . then stalled restarted box started smoking shut down
    and deleted tach adaptor back to 6al only just to make sure .

  4. #4
    Join Date
    Jan 2018
    Posts
    84

    Default

    Where was the ground for the tach adaptor going exactly? For the MSD box we do not recommended the body for a ground we would like it going to either a frame ground battery ground or a ground on the engine block. Also, with the tach adaptor we would like to see the same style of ground or have it go to the same location as the MSD box.

  5. #5
    Join Date
    Sep 2018
    Posts
    6

    Default

    Both to steel part of dash frame. Battery is earthed to frame in boot. Engine is earthed to frame at front of car.

  6. #6
    Join Date
    Sep 2018
    Posts
    6

    Default

    So you believe grounding box and tach to engine will make factory work?is this why it started smoking because of ground to body? Is the tach adaptor now stuffed?

  7. #7
    Join Date
    Jan 2018
    Posts
    57

    Default

    yes sir a bad ground will give you issues. and yes it could be possible that the tach adapter is damaged
    shake-n-bake

  8. #8
    Join Date
    Sep 2018
    Posts
    6

    Default

    is it worth giving the adaptor another go? if it is stuffed can it damage the 6AL?
    the 6AL was working fine with ground to dash.should i find a new ground for the 6AL?
    battery is in boot what is my best option for the ground battery or engine block?

  9. #9
    Join Date
    Sep 2018
    Posts
    6

    Default

    No answer here really. Taken back to supplier. Heaven forbid i have found someone to help. They will test unit showed how its wired in . He believes my earth is ok see the outcome happy to purchase new unit dont want same problems. I will run earth to next hook up just to adhere to your instructions.i will also get the local auto electrician to put in just if i have missed something . I will let you know as all that has happened here is a bad earth.i am not convinced stand by. I also asked how many they sell 1 a week and i have the only problem.

  10. #10
    Join Date
    Jan 2018
    Posts
    57

    Default

    the battery neg. will be the best ground for the MSD system
    shake-n-bake

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •