Results 1 to 4 of 4

Thread: msd atomic tcm 2760 shifting issues 4r70w

  1. #1
    Join Date
    Jun 2018
    Posts
    2

    Default msd atomic tcm 2760 shifting issues 4r70w

    Firstly, I think the moderator should make a section strictly for the TCM units on the forum. I have had a hard time finding any information and really thought there would be more installation and trouble shooting posts. I guess the lack of questions means it works well for most people who install it.


    My setup: 2001 4r70W from an F150 w/ 4.2 V6 behind a mild 351w injected with Fitech 400hp kit in a '64 Galaxie using the MSD 2760 TCM module and harness.

    The trans shifts fine up through the gears from 1st to OD and the torque converter locks in and unlocks at correct MPH and when brake pedal is pushed. Adjusting the settings for firmness and gain makes a difference, so I would say everything is working as it should except one thing.

    When I am in OD and at light throttle (less than 5% TPS opening) it will kick down to 3rd. The controller still shows it is in 4th but i let it drift down to a stop and when it called for the 4th to 3rd downshift there was no change, 3rd to 2nd and 2nd to 1st gave that little downshift bump, but not 4th to 3rd. I had looked in the controller for more advanced settings that ma be causing it but found nothing. I have adjusted the controller settings above and below the defaults and they have made dramatic differences in shift firmness and MPH but it still downshifts when you let out of the gas when it should coast in OD. I was thinking of setting the TPS at 5% open on the controller as the low limit to see if it remedies the problem. Is this acceptable? are there any other functions that may be affected by it not reading 0% TPS closure? I had also read in another poast, that along with the TPS signal wire, the TPS ground maust be hooked as well when piggy backing TPS sensors. I have done that as well. Any help on this would be greatly appreciated.
    Nathan

  2. #2
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    961

    Default

    What road speed are we talking about?

    At 30 mph, it makes sense to 4-3, what does it do at 50 mph?

    I know a few cars that do just that, 4-3 at near zero throttle.
    Regards

    Gary

  3. #3
    Join Date
    Jun 2018
    Posts
    2

    Default

    It is doing it at 55 to 60 mph. I changed the tps to think it is always at 5% and it drove great. I just don't understand why it was doing what it was doing. Unless another drivability issue arises, I'm calling it fixed.

  4. #4
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    961

    Default

    It that works for you, and all the shift pattern is acceptable, that's all that matters.

    Gary
    Regards

    Gary

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •