Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: AFR issues with 408 LS.

  1. #11

    Default

    Quote Originally Posted by frostchevelle1 View Post
    My cam specs are below. This is a custom cam for a turbo 5.3. I tried running mine on the performance setting and it had stumbles and wouldnít run correctly. Set it on mild and updated the software and works much better. Iím running 80lb injectors and 15psi at the moment. About to add water/meth and turn it up. LS engines are more efficient and the cams we are running are not really that aggressive.

    Lift .613 .617
    Duration @ .006 277 281
    valve timing @.050 INT 4 42 EXH 52 1-
    109 centerline
    Duration @ .050 227 231
    Lobe lift .361 .363
    Lobe sep 113
    Rocker arms 1.70
    I messed with idle screw today and I swear things are getting worse?! Car is idling at 11:1 air fuel and literally canít even idle in a garage with the door wide open. Sooo much fuel at idle. Here are my controller pictures, I have tried adding timing, decreasing map and TPS. Please give me some input.

    107FE8F8-413D-40DD-A38D-E1A473F0CDAF.jpeg7275DB65-831D-420E-9B19-807FF2782ECC.jpeg76B49ABD-C90D-45F2-B76C-70383B55E2CB.jpeg

  2. #12
    Join Date
    Nov 2015
    Posts
    108

    Default

    I run mine at 8 and 10% every engine setup will be different. My engine is a stock 5.3 with a custom turbo cam. Your engine may require alittle more fuel on tip in. Also the MAP and TPS adjustment will not do anything for idle. What is your IAC at idle in park and in gear if your running an auto? Also it may sound funny but try the stock setting and see how it does.

  3. #13
    Join Date
    Nov 2015
    Posts
    108

    Default

    Try using the stock setting for cams and see what it does. Your pulling a lot of vacuum yet you have little timing and running rich. Also you have to let the engine warm up before it will learn. Learning mode is off. Kinda odd your using 4% injector duty cycle at idle. Mine runs at 1%.

  4. #14
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    897

    Default

    17 inches is a mild cam, so try the stock cam setting.
    Regards

    Gary

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •