Results 1 to 8 of 8

Thread: MSD street fire pn5520 5al

  1. #1
    Join Date
    Apr 2018
    Posts
    6

    Default MSD street fire pn5520 5al

    Hi tech support. I am at wits end . I from Australia. have purchased an msd 5al street fire, it is in a 351 cleveland xb falcon and its been cutting out from new every 4 to 5 minutes. I have checked everything and I mean checked. It is matched with a msd Blaster 2 coil and a duraspark distributor magnetic pickup . Item was purchased 20/1/2018 and car has travelled less than 12 klms. Can you help me Contact Peter email pioda@tpg.com.au

  2. #2
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    955

    Default

    Hi Peter,
    Cutting out at idle only, or some rpm while driving?
    What carburettor and camshaft etc?
    Gary
    Regards

    Gary

  3. #3
    Join Date
    Apr 2018
    Posts
    6

    Default

    normal driving complete cut out. you switch ignition off and away you go again.

  4. #4
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    955

    Default

    Does everything else that is ignition switch fed still work when this occurs?
    Electric fuel pump, cooling fans etc?
    Regards

    Gary

  5. #5
    Join Date
    Apr 2018
    Posts
    6

    Default

    I can put the small red wire (ignition feed) straight to the battery + and it will still cut out. makes no different.

  6. #6
    Join Date
    Jan 2018
    Posts
    82

    Default

    How is the ground for the 5520 wired?

  7. #7
    Join Date
    Apr 2018
    Posts
    6

    Default

    msd unit is ground to battery neg. I have ground straps from engine to body, battery to engine and battery to body.I have run the unit out of the car on the bench connected to the blaster coil and duraspark distributor and it did the same .you could see an intermitent spark at about 4 minutes. stop and started it again was ok. tested it on and off for about 4 days. put it back in car same sh#t.

  8. #8
    Join Date
    Apr 2018
    Posts
    6

    Default

    MSD tech20. I need a response . why does it take so long to communicate. this unit is under warranty. I have also sent emails to tech support????

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •