Results 1 to 3 of 3

Thread: deceleration backfire

  1. #1
    Join Date
    Mar 2018
    Posts
    4

    Default deceleration backfire

    What causes the system to backfire and lean out when doing off throttle deceleration?

  2. #2
    Join Date
    Aug 2014
    Posts
    6

    Default

    I have the same issue, not sure if this helps or not, but have read elsewhere that if the heat cross over in the intake manifold is blocked off, the backfire in exhaust can result. I have my crossover blocked. One other thing I have experienced with the quick de-cell is the idle AFR setting makes a big difference. I had mine on the rich side, and have since leaned it out to 14.3 or so and some of my de-cell issues have subsided.

  3. #3
    Join Date
    Mar 2018
    Posts
    4

    Default

    Quote Originally Posted by Rebuildman View Post
    I have the same issue, not sure if this helps or not, but have read elsewhere that if the heat cross over in the intake manifold is blocked off, the backfire in exhaust can result. I have my crossover blocked. One other thing I have experienced with the quick de-cell is the idle AFR setting makes a big difference. I had mine on the rich side, and have since leaned it out to 14.3 or so and some of my de-cell issues have subsided.
    Thank for the tip. Iíve also tried a little more total timing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •