Results 1 to 9 of 9

Thread: Cooling mist water methanol

  1. #1
    Join Date
    Oct 2016
    Posts
    10

    Default Cooling mist water methanol

    Hello,

    I have a SBC with a draw through turbo system. I'm using the Msd Atomic and I have a cooling mist setup for cooling. Can this cause issues on the afr reading's on the Atomic? I'm getting black smoke on full throttle.

    Thanks,
    Erik

  2. #2
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    955

    Default

    Hi Erik,

    A few things happen here.
    First up, the IAT gets drowned in fluid spray, so the inlet air temp would read lower than actual.
    The splitting of the water creates hydrogen and oxygen, plus the the additional fuel(methanol) creates a more complete combustion process.
    The O2 sensor reads leaner than target, so the fuelling goes richer.
    My question back is why draw through, and not blow through.
    Your turbo compressor blade might be happier as a blow through.

    Gary
    Regards

    Gary

  3. #3
    Join Date
    Oct 2016
    Posts
    10

    Default

    Hi Gary,

    Turbo system is a old one from Martin industry's with a Rajay turbo. It's got a nice power curve and now turbo lag because it's got a 2 piece intake with valves in it if there is no boost the valves are open and the engine is na. When there is boost the valves get closed and the engine gets boost. The methanol is injected after the turbo. It's not going through the Atomic.
    My only concern is the O2 sensor I was reading about methanol and afr ratio they say when you have a afr of 11.5 without methanol. Your going to have a afr of 10.5 with methanol.
    I don't know how the Atomic is going to respond to this.

    Thanks,
    Erik

  4. #4
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    955

    Default

    Ah ok, I remember that setup.
    What are your target A/F ratios?
    Gary
    Regards

    Gary

  5. #5
    Join Date
    Oct 2016
    Posts
    10

    Default

    Any help would be appreciated. Test drove the car yesterday. And at full throttle I see the afr drop to 6 car starts spitting and alot of black smoke.

    These are my present Atomic settings:

    Cubic Inch: 355*

    Cyl: 8

    Cam: mild

    Fuel Pump: .non PWM with regulator

    46psi

    Idle target: 850

    Rev limit: 6000

    Timing control: Enabled


    A/F: idle 13.5, cr 14.6, WOT 12.8, boost 12.4

    Ign timing:

    ******* Idle RPM:
    900

    * * * *Tot RPM:
    2,200

    * * * *Idle
    advance: 19.0

    * * * *Total
    advance: 33.0

    * * * *Vac
    advance: 15.0

    Boost retard 1.0

    * * * *Vacuum
    Type: unported

    Pump squirt: 19%

    Power Valve Enrich: 30%

    *

    Firmware Versions

    04/01/2013

    2.0.7 Dash

    1.2.10 ECU

    1.0.9 Power Mod.

  6. #6
    Join Date
    Oct 2016
    Posts
    10

    Default

    This is the cam I'm using:

    Xtreme Turbo Hydraulic Flat Tappet Camshaft
    Small Block Chevy 262-400 1955-98
    Lift: .432"/.426"
    Duration: 250/257
    Lobe Separation Angle: 110°
    RPM Range: 1200-5500

  7. #7
    Join Date
    Oct 2016
    Posts
    10

    Default

    Any help/ideas would be appreciated

  8. #8
    Join Date
    Jan 2010
    Location
    Brisbane, Australia
    Posts
    955

    Default

    I would hope an MSD tech can help now.

    Gary
    Regards

    Gary

  9. #9
    Join Date
    Oct 2016
    Posts
    10

    Default

    MSD Tech I would appreciate it if you could give some help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •