Results 1 to 2 of 2

Thread: Sled com error c

  1. #1
    Join Date
    Dec 2017
    Posts
    6

    Default Sled com error c

    I purchased the MSD Atomic LS #2950.
    Its installed on an LS1 with the adapter kit.
    I have the correct cam and crank sensor connectors installed.
    I installed it a week ago and the engine started and ran fine.
    Intermittently the engine would cut out or not fire up and the diagnostics on the hand held would say SLED COM ERROR C.
    I have double checked all the connectors and grounds.
    When I pressed against the CAN cable at the power module the error would clear for a short period, the engine would start, cut out and the error code return. Now the error will not clear and the engine will not fire up at all.
    I think the CAN Cable or the power module connectors may be faulty.

    Can you please assist

    Steve

  2. #2
    Join Date
    Dec 2017
    Posts
    6

    Default

    IMG_0847.JPG
    IMG_0848.JPG

    An update on the MSD Atomic LS installation error.
    Tech support have contacted me.
    The error code means the fuel rails have stopped communicating with the power unit and hand held.

    The attached pics show that under DISPLAY SETUP/FIRMWARE VERSIONS both fuel rails show an error. this must mean that both have stopped communicating with the power unit and hand held. Also shows the latest updates are installed on the micro SD Card.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •